Ë
    ì—0jt   ã                   ót   — d dl mZmZmZ ddgZ ee«       G d„ d«      «       Z ee«       G d„ d«      «       Zy)é    )ÚStrEnumÚIntEnumÚ_simple_enumÚ
HTTPStatusÚ
HTTPMethodc                   ó`  — e Zd ZdZdGd„Zed„ «       Zed„ «       Zed„ «       Zed„ «       Z	ed„ «       Z
dZd	Zd
ZdZdZdZdZdZdZdZdZdZdZdZdZdZdZdZdZdZdZdZ dZ!dZ"d Z#d!Z$d"Z%d#Z&d$Z'd%Z(d&Z)d'Z*d(Z+d)Z,d*Z-d+Z.d,Z/d-Z0d.Z1d/Z2d0Z3d1Z4d2Z5d3Z6d4Z7d5Z8d6Z9d7Z:d8Z;d9Z<d:Z=d;Z>d<Z?d=Z@d>ZAd?ZBd@ZCdAZDdBZEdCZFdDZGdEZHyF)Hr   aG  HTTP status codes and reason phrases

    Status codes from the following RFCs are all observed:

        * RFC 7231: Hypertext Transfer Protocol (HTTP/1.1), obsoletes 2616
        * RFC 6585: Additional HTTP Status Codes
        * RFC 3229: Delta encoding in HTTP
        * RFC 4918: HTTP Extensions for WebDAV, obsoletes 2518
        * RFC 5842: Binding Extensions to WebDAV
        * RFC 7238: Permanent Redirect
        * RFC 2295: Transparent Content Negotiation in HTTP
        * RFC 2774: An HTTP Extension Framework
        * RFC 7725: An HTTP Status Code to Report Legal Obstacles
        * RFC 7540: Hypertext Transfer Protocol Version 2 (HTTP/2)
        * RFC 2324: Hyper Text Coffee Pot Control Protocol (HTCPCP/1.0)
        * RFC 8297: An HTTP Status Code for Indicating Hints
        * RFC 8470: Using Early Data in HTTP
    c                 ó\   — t         j                  | |«      }||_        ||_        ||_        |S ©N)ÚintÚ__new__Ú_value_ÚphraseÚdescription)ÚclsÚvaluer   r   Úobjs        ú*/usr/local/lib/python3.12/http/__init__.pyr   zHTTPStatus.__new__   s,   € Ü�k‰k˜#˜uÓ%ˆØˆŒàˆŒ
Ø%ˆŒØˆ
ó    c                 ó"   — d| cxk  xr dk  S c S )Néd   éÇ   © ©Úselfs    r   Úis_informationalzHTTPStatus.is_informational"   ó   € à�dÖ!˜cÑ!Ð!Ñ!Ð!r   c                 ó"   — d| cxk  xr dk  S c S )NéÈ   i+  r   r   s    r   Ú
is_successzHTTPStatus.is_success&   r   r   c                 ó"   — d| cxk  xr dk  S c S )Né,  i�  r   r   s    r   Úis_redirectionzHTTPStatus.is_redirection*   r   r   c                 ó"   — d| cxk  xr dk  S c S )Né�  ió  r   r   s    r   Úis_client_errorzHTTPStatus.is_client_error.   r   r   c                 ó"   — d| cxk  xr dk  S c S )Néô  iW  r   r   s    r   Úis_server_errorzHTTPStatus.is_server_error2   r   r   )r   ÚContinuez!Request received, please continue)ée   zSwitching Protocolsz.Switching to new protocol; obey Upgrade header)éf   Ú
Processing)ég   zEarly Hints)r   ÚOKz#Request fulfilled, document follows)éÉ   ÚCreatedzDocument created, URL follows)éÊ   ÚAcceptedz/Request accepted, processing continues off-line)éË   zNon-Authoritative InformationzRequest fulfilled from cache)éÌ   z
No Contentz"Request fulfilled, nothing follows)éÍ   zReset Contentz"Clear input form for further input)éÎ   zPartial ContentzPartial content follows)éÏ   zMulti-Status)éÐ   zAlready Reported)éâ   zIM Used)r!   zMultiple Choicesz,Object has several resources -- see URI list)i-  zMoved Permanentlyú(Object moved permanently -- see URI list)i.  ÚFoundú(Object moved temporarily -- see URI list)i/  z	See Otherz'Object moved -- see Method and URL list)i0  zNot Modifiedz)Document has not changed since given time)i1  z	Use Proxyz@You must use proxy specified in Location to access this resource)i3  zTemporary Redirectr<   )i4  zPermanent Redirectr:   )r$   zBad Requestz(Bad request syntax or unsupported method)i‘  ÚUnauthorizedz*No permission -- see authorization schemes)i’  zPayment Requiredz"No payment -- see charging schemes)i“  Ú	Forbiddenz0Request forbidden -- authorization will not help)i”  z	Not FoundzNothing matches the given URI)i•  zMethod Not Allowedz-Specified method is invalid for this resource)i–  zNot Acceptablez%URI not available in preferred format)i—  zProxy Authentication Requiredz7You must authenticate with this proxy before proceeding)i˜  zRequest Timeoutz"Request timed out; try again later)i™  ÚConflictzRequest conflict)iš  ÚGonez5URI no longer exists and has been permanently removed)i›  zLength Requiredz"Client must specify Content-Length)iœ  zPrecondition Failedz Precondition in headers is false)i�  zRequest Entity Too LargezEntity is too large)iž  zRequest-URI Too LongzURI is too long)iŸ  zUnsupported Media Typez!Entity body in unsupported format)i   zRequested Range Not SatisfiablezCannot satisfy request range)i¡  zExpectation Failedz'Expect condition could not be satisfied)i¢  zI'm a Teapotz5Server refuses to brew coffee because it is a teapot.)i¥  zMisdirected Requestz(Server is not able to produce a response)i¦  zUnprocessable Entity)i§  ÚLocked)i¨  zFailed Dependency)i©  z	Too Early)iª  zUpgrade Required)i¬  zPrecondition Requiredz8The origin server requires the request to be conditional)i­  zToo Many RequestszOThe user has sent too many requests in a given amount of time ("rate limiting"))i¯  zRequest Header Fields Too LargezVThe server is unwilling to process the request because its header fields are too large)iÃ  zUnavailable For Legal ReasonszOThe server is denying access to the resource as a consequence of a legal demand)r'   zInternal Server ErrorzServer got itself in trouble)iõ  zNot Implementedz&Server does not support this operation)iö  zBad Gatewayz+Invalid responses from another server/proxy)i÷  zService Unavailablez8The server cannot process the request due to a high load)iø  zGateway Timeoutz4The gateway server did not receive a timely response)iù  zHTTP Version Not SupportedzCannot fulfill request)iú  zVariant Also Negotiates)iû  zInsufficient Storage)iü  zLoop Detected)iþ  zNot Extended)iÿ  zNetwork Authentication Requiredz7The client needs to authenticate to gain network accessN)Ú )IÚ__name__Ú
__module__Ú__qualname__Ú__doc__r   Úpropertyr   r   r"   r%   r(   ÚCONTINUEÚSWITCHING_PROTOCOLSÚ
PROCESSINGÚEARLY_HINTSr.   ÚCREATEDÚACCEPTEDÚNON_AUTHORITATIVE_INFORMATIONÚ
NO_CONTENTÚRESET_CONTENTÚPARTIAL_CONTENTÚMULTI_STATUSÚALREADY_REPORTEDÚIM_USEDÚMULTIPLE_CHOICESÚMOVED_PERMANENTLYÚFOUNDÚ	SEE_OTHERÚNOT_MODIFIEDÚ	USE_PROXYÚTEMPORARY_REDIRECTÚPERMANENT_REDIRECTÚBAD_REQUESTÚUNAUTHORIZEDÚPAYMENT_REQUIREDÚ	FORBIDDENÚ	NOT_FOUNDÚMETHOD_NOT_ALLOWEDÚNOT_ACCEPTABLEÚPROXY_AUTHENTICATION_REQUIREDÚREQUEST_TIMEOUTÚCONFLICTÚGONEÚLENGTH_REQUIREDÚPRECONDITION_FAILEDÚREQUEST_ENTITY_TOO_LARGEÚREQUEST_URI_TOO_LONGÚUNSUPPORTED_MEDIA_TYPEÚREQUESTED_RANGE_NOT_SATISFIABLEÚEXPECTATION_FAILEDÚIM_A_TEAPOTÚMISDIRECTED_REQUESTÚUNPROCESSABLE_ENTITYÚLOCKEDÚFAILED_DEPENDENCYÚ	TOO_EARLYÚUPGRADE_REQUIREDÚPRECONDITION_REQUIREDÚTOO_MANY_REQUESTSÚREQUEST_HEADER_FIELDS_TOO_LARGEÚUNAVAILABLE_FOR_LEGAL_REASONSÚINTERNAL_SERVER_ERRORÚNOT_IMPLEMENTEDÚBAD_GATEWAYÚSERVICE_UNAVAILABLEÚGATEWAY_TIMEOUTÚHTTP_VERSION_NOT_SUPPORTEDÚVARIANT_ALSO_NEGOTIATESÚINSUFFICIENT_STORAGEÚLOOP_DETECTEDÚNOT_EXTENDEDÚNETWORK_AUTHENTICATION_REQUIREDr   r   r   r   r      s   „ ñó$ð ñ"ó ð"ð ñ"ó ð"ð ñ"ó ð"ð ñ"ó ð"ð ñ"ó ð"ð D€Hð>Ðà"€JØ$€Kð 
:€BØ=€Gð;€Hð%IÐ!àH€JØN€MØG€OØ&€LØ.ÐØ€Gð8Ðð4ÐàD€EØK€Ið5€LðL€Ið4Ðð4Ðð4€Kð6€Lð.Ðð<€Ið)€Ið9Ðð1€Nð%CÐ!ð.€Oà2€HðA€Dð.€Oð,Ðð ÐðÐð-Ðð'(Ð#ð3ÐðA€Kð4Ðà6ÐØ€FØ0ÐØ €IØ.ÐðDÐð4Ðð' Ð#ð%7Ð!ð(Ðð2€Oð7€KðDÐð@€Oð""Ðà<ÐØ6ÐØ(€MØ&€Lð'CÑ#r   c                   ó@   — e Zd ZdZd„ Zd„ ZdZdZdZdZ	dZ
d	Zd
ZdZdZy)r   zÏHTTP methods and descriptions

    Methods from the following RFCs are all observed:

        * RFC 7231: Hypertext Transfer Protocol (HTTP/1.1), obsoletes 2616
        * RFC 5789: PATCH Method for HTTP
    c                 óN   — t         j                  | |«      }||_        ||_        |S r
   )Ústrr   r   r   )r   r   r   r   s       r   r   zHTTPMethod.__new__·   s%   € Ü�k‰k˜#˜uÓ%ˆØˆŒØ%ˆŒØˆ
r   c                 óP   — d| j                   j                  ›d| j                  ›d�S )NÚ<Ú.Ú>)Ú	__class__rC   Ú_name_r   s    r   Ú__repr__zHTTPMethod.__repr__½   s   � Ø ŸN™N×3Ó3°T·[³[ÐAÐAr   )ÚCONNECTz%Establish a connection to the server.)ÚDELETEzRemove the target.)ÚGETzRetrieve the target.)ÚHEADzBSame as GET, but only retrieve the status line and header section.)ÚOPTIONSz2Describe the communication options for the target.)ÚPATCHz(Apply partial modifications to a target.)ÚPOSTz<Perform target-specific processing with the request payload.)ÚPUTz,Replace the target with the request payload.)ÚTRACEz>Perform a message loop-back test along the path to the target.N)rC   rD   rE   rF   r   rŽ   r�   r�   r‘   r’   r“   r”   r•   r–   r—   r   r   r   r   r   ®   sB   „ ñòòBð A€GØ+€FØ
'€CØW€DØM€GØ?€EØQ€DØ
?€CØU�Er   N)Úenumr   r   r   Ú__all__r   r   r   r   r   Ú<module>rš      s[   ðß /Ñ /à˜Ð
&€ñ ˆgÓ÷dCð dCó ðdCñN ˆgÓ÷Vð Vó ñVr   